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Introduction

 Welcome to the FreeStyler Guide. This was written to expand knowledge of the 
FreeStyler program and introduce a new user to Digital Multi-Plex (DMX) 
programming. In this guide you will learn:

● The uses of DMX

● How to think while programming in DMX

● Some DMX terminology

● The use of a lighting desktop

● Ways to use “Macros”

● The different styles of programming that can be used in the FreeStyler Program

● How to set your programs to react to sound and time

● And much more.....

With that out of the way, let's get started with DMX!!! 

*This guide was intended for OurDJTalk.com ONLY!!! This guide is intended to be free 
and may NOT be redistributed, edited, or sold without written permission from myself.

**Please do not post this anywhere else unless you ask me. You can contact me at my 
email address: 

rlelek@emailaccount.com

*** Please donate to FreeStyler on their website. Programming takes much time and 
effort to complete, not including the expenses needed to program. Donating a few 
dollars will help keep this program alive and not require you to pay for expensive and 
sometimes mediocre interfaces.

Thank You!!!



Chapter 1
In this chapter, we will configure FreeStyler. This is one of the most crucial steps 

in DMX programming. If you do not set up your DMX interface or address your fixtures 
correctly, you will find yourself with multiple problems, so let's do it correctly the first 
time. Well, let's get started already!!!

Please follow the instructions listed below:

● Go to the following site to download FreeStyler.

http://users.pandora.be/freestylerdmx/

● After the download is complete, it is time to install. Open up the executable file 
and the installation will start. Follow the on-screen instructions and install all of 
the features. Restart your computer after the installation completes.

*I will not be using “Magic 3D Easy View” in this guide, so you do not have to 
download or install it unless you would like to.

● Open FreeStyler and you will then be greeted by a pop up menu. Click on the 
Next button and select the interface you plan on using. If you do not have an 
interface, you should select Virtual Interface from the drop down menu. Click the 
Next button once you have selected your interface.

● You will now be asked to address the fixtures you will be using. For the sake of 
this guide, we will be using two MAC300's and two MANIA SCX500's which are 
both manufactured by Martin. To address the fixtures, scroll down the list on the 
left side until you find the manufacturer's name (Martin) and double click it. Then, 
find the fixtures you want to use (MAC300 and MANIA SCX500) and highlight 
one of them. Drag and drop the fixture from the left list into the blank right list (or 
click the right-facing arrow) and a new pop up will appear. It will ask what row 
you would like to start placing fixtures in and the number of that particular fixture 
you want to add. For this guide, we will start at Row 1 and add two MAC300 
fixtures. Make sure Auto Address and Auto Create Group have checks next to 
them and click Add. 



*We will talk about manual addressing and groups later on. If you have your 
fixtures hooked up, they will probably not work because when we selected Auto 
Address,  FreeStyler picked an address that wasn't being used by any other fixture. 

● We add other fixtures in the same way. Add two SCX500 fixtures now and try not 
to look back at this as you must become comfortable doing this and not rely on a 
guide.

● When both the MAC's and SCX's are configured, click on Close.

● You should now see a gray screen with two MAC 300's and two SCX500's on it. 
This is what is known as your Lighting Desktop or just Desktop for short. Almost 
everything you do in FreeStyler will involve using the Desktop. It will become 
one of your best friends. Take a quick moment now to get yourself familiar with 
its layout. You are able to customize your desktop according to your needs, but we 
will talk about that later. For now, click on a fixture and take note of what color it 
turns. If you did not change any of the default settings (and you didn't if you are 
following this guide), the fixture's name should turn from a dark blue to a lighter 
blue. Now, click on another fixture. Note the colors again. The previously selected 
fixture turns RED, and the “Primary” fixture turns LIGHT BLUE while 
unselected fixtures remain DARK BLUE. Understand this color scheming before 
moving on as it is essential to programming and knowing which fixtures are 
affected

*Please note: if you click anywhere on the desktop, all fixtures become 
unselected. 

**Tip: when selecting fixtures, click on the icon and not the name. If you notice 
you cannot open any attribute windows, this is probably why. For some reason, 
FreeStyler will not open any attribute windows when the “typing cursor” is shown 
in the  fixture's name.

● Now, Make sure BOTH MAC300's are selected (one will be red, the other will be 
light blue, and the SCX500's will remain dark blue). It is time to start exploring 
“attributes” which are the different things a light offers for programming. 
Attributes almost always include pan, tilt, gobo, and color, but this is not always 
the case. FreeStyler will automatically disable features that are not available for 
the selected fixtures. However, if two different fixtures are selected, the only 
attributes that will be displayed are the ones the fixtures have in COMMON. 
Please look  at the toolbar directly above the Desktop. Here are the descriptions of 
the buttons from left to right...



FreeStyler's Main Toolbar

Select All Fixtures Selects all fixtures
Deselect All Fixtures Deselects all fixtures
Lamp Settings Opens the Lamp configuration window 

(shutter, dimmer, and strobe)
Gobo Opens the Gobo configuration window
Color Opens the Color configuration window
Pan/Tilt Opens Movement window with a 

coordinate plane for selecting a light's 
position

Iris, Focus, Zoom,... (Beam) Opens the Beam configuration window
Fixture Macros (Special) Opens the Special Fixture Functions 

configuration window
Show All Panels Shows/Hides the Lamp, Gobo, Color, 

Pan/Tilt, Beam, and Special windows
Magic 3D Easy View Opens the Sunlite Visualizer (if installed)
Create Sequence Make/Edit your Scenes/Sequences
Cue Lists all Sequences/Scenes for playback
Programmable Override Buttons A group of assignable buttons that *#*#$#
Submasters A kind of cue list that offers “Dimming”
Sound To Light This will let Fixtures or Sequences react to 

the beat of the sound (if allowed)
Fogger Control Controls configured Fog Machines
DMX 400 A Four Channel Chaser with programs
Toggle Blackout Turns all Fixtures On/Off
Toggle Favorite Just like Blackout but acts like a Scene
Toggle Freeze Will instantly “Freeze” fixtures in their 

current position when pressed.
Master Intensity Controls all Fixtures' brightness



● Print the above list if you think it will prove useful. I recommend doing this so 
you can have a reference sheet while following this guide and when programming 
your own sequences. There are still a few buttons unmentioned, but what has been 
mentioned should keep you plenty busy for now. 

● Let's select both MAC300's again if they were unselected. Now, click on the 
“Show All Panels” button. You should see many windows pop up. You should 
configure these to where you are most comfortable having them and then click on 
the little “lock” icon to lock them in place. 

*Please note: Different fixtures have different attributes available and different 
variables for those attributes. Therefore, the attribute windows may change in size 
or even disappear completely. You may have to move your “locked” windows in 
order to show the whole thing and not have any other windows overlapping it.

● Let's now talk about how the windows for the MAC300's work. There should be 
three windows open: Lamp, Color, and Pan/Tilt. The lamp is the most crucial 
attribute to be worried about. Almost all of the time, if you do not see your lights 
working, it is because of the configuration in the Lamp window. There are two 
ways to “turn” on a lamp. First, there is the common way, and, in my opinion, the 
most proper. This way is by using the “shutter” to prevent the light emitted from 
the light bulb from exiting the fixture. Because most fixtures use a shutter, it is 
good to get in the habit of “turning” your lamp off in this way not only because 
you save strain on your bulb, but also because it is usually much quicker for doing 
strobe effects and such. The is another way to “turn” off your bulb and it involves 
physically turning off the bulb instead of just blocking the light it emits. To my 
understanding, the only lamps you must actually “strike” or “turn on” are called 
“Arc Lamps.” I also believe regular halogen bulbs turn on when the fixture is 
plugged in and the fixture then uses the shutter to turn itself “off.” Though “Arc 
Lamps” are halogen, they still must be “struck” by a signal sent from the 
controller. Feel free to correct me here, but this is what I understood. Anyway, in 
either case, it is better to just keep you lamps turned “on” all the time and use only 
the shutter to turn them “off.”

● Underneath the shutter selection, you will notice a “bar” (which is really called a 
“slider”) next to a lightning bolt with Low, Med, and High buttons below it. This is 
what I like to call the “Strobe Section.” This is basically where you will do most 
of your strobing, provided your fixture offers this attribute. I have found that the 
lower the number is on the slider, the faster the strobing becomes. Therefore, Low 
is really fast strobing and High is really slow strobing while Med is in the middle. 
The Low, Med, and High buttons are presets for the slider above them, so you 
should experiment with this slider when you get your lights up and running, 



whether it be physically or in a visualizer (which is going to be coming up soon!)

● Below the “Strobe Section” is the “Intensity.” Intensity is the brightness of the 
fixture. This can usually be obtained by the shutter, but may also be made by 
actual dimming of the bulb (again, correct me if I am wrong).

● Notice the “Lamp” icon beneath the “Intensity.” this is how to “strike” your lamp 
either “on” or “off.” As stated before, I recommend keeping the lamp on all the 
time and using the shutter to dim/turn off the fixture. The only time you should 
physically turn off the lamp is when you will not be using your fixture for an 
extended period of time.

● By assuring the shutter is set to “Open” and the Intensity is set to “100%” this 
usually means your light is shining its brightest (and that is pretty bright in most 
cases). Now, Let's move on to more fun attributes to play around with...

● With the Lamp configuration out of the way, we can start having some fun now. 
Please move to the Color configuration window. This provides you with a “color 
wheel” (or “color block” rather) in which all colors the fixture can output are 
present. Because the MAC300's are technically classified as a “Wash” they do not 
offer gobo selection, but make up for it in color selection. While most fixtures 
with gobos have a 22 color max, the MAC300 can output much more than the 
standard Yellow, Red, Blue, and Green, but everything else in between. Simply 
drag around in the “color block” and see the color displayed below it. 

*Please note: The box on the left gives you a preview of the color your cursor is 
currently at. The right box shows the selected color that will be outputted to the 
fixture. To change this at any time, all you have to do is click either the right or 
left mouse button upon you new color selection.

● The last attribute for the MAC300's is the Movement. If you could not move the 
fixture, it probably would not be that much fun or awe inspiring for the crowd. It 
is a good thing you can though. The Movement window is rather simple to 
understand (for now anyway). The middle of the coordinate plane (that's that cross 
thing :D) is what I like to call the “Home Position.” No matter where I am, I 
usually find myself starting back at the home position because it allows me to 
better control the light. If you ever lose sight of your light beam, you can always 
bring it back to the Home Position by clicking the “Center” button inside the 
arrows off to the side. These arrows allow for the fine tuning of your fixture's 
beam, but you will probably almost always use your mouse to move a light beam 
to a new position. All you have to do is drag and drop the little “ball” to a new 
position. Okay, I know EXACTLY what you are thinking right now if you are 



going through this guide without having your fixtures hooked up. You are asking, 
“But how do I know WHERE to move the fixture's beam?” That is one of the best 
questions to be asking. It is one of the BEST reasons to do your DMX 
programming on the computer as well. But what am I getting at? I think you know 
by now, and I am not going to get into that until tomorrow.......

● Please deselect the MAC300's by either clicking on both again or by clicking in 
an empty part of the desktop. Now, select both SCX500's. Once again click the 
“Show All Panels” button on the toolbar to open up every attribute the SCX500 
offers. You should see the following windows: Lamp, Colors, Gobos, Macros, and 
Movement. If you do not see all of these windows it is either because:

You did not press the “Show All Panels” after you made your selection

OR

You still have a MAC300 selected.

● Once you have all the windows open, it is time to point out some differences in 
attributes that make each light unique. Notice the Colors window first. Do you see 
as many color choices as the MAC300 had before? The answer is no, but for 
every loss, there is a gain and this gain just happens to be Macros and Gobos. 
Macros will not be worried about as of now because they can be complex at times 
and I do not want to drown you anymore than I have already with information. 
Gobos are technically patterns usually made from metal in the form of discs, but 
other types occur such as glass. The other types of gobos and their features (such 
as being replaceable) usually occur in higher end systems with rotating gobos, 
especially moving heads. Go ahead and do some lighting research if you have not 
already. 

● Okay, that pretty much wraps up this chapter!!! Congratulations if you have 
gotten this far. You probably know more about lighting now than you ever wanted 
to know and are wondering what to do with all the information you have just 
received. Well, I have an answer for you!!! Put it to good use. Remind yourself 
every single day what these terms mean and try to be as descriptive as possible. 
Before you know it, these words will become part of your vocabulary and you 
will start to slip while talking among your friends and family just as I have. Then 
you can tell them with confidence what it means and why it is significant. And 
soon enough, you can tell them all the good times you had programming a 
“lighting robot” and making it do what you want, whether that be fade your lights 
on at 6:04 PM sharp, or move around to the music. The possibilities are simply 
endless and are only limited by your imagination. 



● Ready to see what you know/need to work on? close out of  everything except for 
this document and scroll down..... I sure hope you listened.....

Chapter 1 Quiz
Do not worry about this test. This is simply a tool to help you. It will show you 

what you know and what you need to work on. Please do not cheat on this test. It is here 
to help you and nobody will ever see it. If you cheat on this you are cheating yourself 
out of knowledge and that is not a good thing. You came here for knowledge, and you 
got this far. Take the test. You may be surprised on how much you now know. Take out a 
sheet of paper and begin.

1. What is an attribute?
2. What is a gobo?
3. What should you use to “turn off” your fixture for a short period of 

time?
4. Assuming you use the default colors, what color are/is...

unselected fixtures?
a PRIMARY fixture?
SECONDARY fixtures?

5. What does DMX stand for?
6. What is this program called?
7. Name one fixture we used in this chapter.
8. What is a fixture?
9. When you are in the Movement window, you drag and drop a ______.
10. When strobing, The lower the the value on the fader, it generally goes 

________.



Chapter 1 Quiz Answers

1. An attribute is anything a fixture can do and it can usually be 
programmed.

2. A gobo is a pattern
3. You should use the shutter to “turn off” the light for a short period of 

time
4. Unselected = Dark Blue

Primary = Light Blue
Secondary = Red

5. Digital Multiplex
6. FreeStyler
7. MAC300 or SCX500
8. A fixture is something usually a light that can be programmed and has 

at least one attribute.
9. Ball
10. Faster

I sure hope you had as much fun as I did!!! This is my first guide EVER 
and I want to thank you for reading it!!! I hope you learned many valuable 
things here and a few other things not even related to FreeStyler. I will be 
making the next chapter in a few days and it will be posted on 
OurDJTalk.com. Once again, thank you for your time, and if you have any 
suggestions, comments, or other ideas from this guide, feel free to post them 
on OurDJTalk. The thread is named “The FreeStyler Guide.” 

For now, I am leaving you, but I will be back, sooner than you know.....

rlelek



Chapter 2

In the previous chapter, you got comfortable using FreeStyler and 
viewed different attributes of your fixtures. Now it is time to start 
programming. Do not fear, this is a relatively short chapter and we will only 
be covering about four different things. First, we will explore “Scenes” and 
what one consists of. After that, we will make a “Sequence” out of created 
scenes. Finally,  we will make a “Cue” out of all the sequences. Okay then, 
let's get started........

Please use the following list as a reference while reading this chapter.

Attribute
Something a Fixture can do that can 

often be programmed .
(Intensity, Pan/Tilt, Gobo, Color,...)

Scene (Step)
A combination of programmed 
attributes. Think of a scene as a 

“snapshot” or frame of animation.

Sequence
A sequence is a combination of 

scenes (frames) strung together to 
make an “animation” of your fixtures.

Cue
 A cue consists of many sequences 
that are executed by either sound, 

timecode, or manual control

● Now, let's start by opening FreeStyler and selecting both MAC300's.

● Open all attribute windows by clicking on the Show All Panels button.

● Set the attributes to anything you like as of right now, but make sure 
you open the shutter and set the intensity to 100%. Set the Pan/Tilt in 
one of the four corners.



● You are now done setting the attributes for the first scene as FreeStyler 
automatically makes a new scene if a saved sequence is not active when 
you edit an attribute. We are now going to add a few more scenes and 
make a sequence out of them.

● Click on the Create Sequence button. A window should pop up. 

*Please note that Scenes are called “Steps” in this program, but refer to 
the same thing in DMX programming, a “snapshot” or frame of the 
fixtures' animation.

● First, let's look at the gray box in the center of the window. This box 
will show you what scene/step you are on and how many scenes/steps 
are in the current sequence. This will be shown in the following format:

Current Step / Total Number of Steps

Also in the gray box are two “time factors” as I call them. One is named 
Fade and the other, Speed. The Fade controls how long the Fade Time will be 
if Fade is selected from Off/Snap/Fade for the attributes (this will be 
explained in Chapter 4: Advanced Programming) whilst the Speed controls 
the length of the scene/step. You can change either the Fade or Speed 
variables by using the two sets of up/down arrows below the gray box. One is 
named Fade Time and the other, Scene Time. Below these sets of arrows are 
another part of the Fade and Speed settings. Both Fade Time and Scene Time 
can by set to all of the scenes/steps by checking the Global Fade/Global  
Scene Time buttons. Keep in mind, if you do this, all previous times are 
erased and are irretrievable unless you saved the sequence beforehand. The 
last button that controls the Fade and Speed variables is the Sync Fade/Scene 
Time button that, when checked, will automatically keep the Fade/Scene time 
identical.

Now, back to the gray box. You will recall the  Step 1/1 from earlier, and we 
will now start to edit this setting. To add a scene/step to your sequence, you 
must press the “plus” button off to the right. When pressed, this button will 
add one scene. Please click this icon twice, so we may add two scenes to the 



current one for a total of three scenes.

*Please note:  When adding scenes, your current settings from the 
previous scene will be applied to the new scenes.

Okay, so we now have three scenes or “frames” in which to program. It is up 
to you which attributes to change in the following instructions. I cannot put 
any locks on your mind, so do whatever you like. After all, this is your show. 
The only thing I am doing is showing you how to create it. 

Let's go to scene one and edit it. If you set it to your likings before, there is 
no need to change this scene.

We are now going to advance to scene/frame two. To do this, simply open up 
the Create Sequence button and click on the right-facing single arrow. 

*When you click on the single arrows, they will advance or go back to a 
scene, one scene per click. 

In the gray box, the Step field should now read “2/3” to indicate you are at 
scene two out of the total of three scenes.

Once again, edit this scene, but please change a few attributes. For example, 
in scene one my color was green, but in scene two, it is changed to purple. 

*Please note: Though you do not have to change attributes in the scenes, 
because the sequence will still run if you don't, it only makes sense to change 
them. You may be asking yourself, “Why?” and the answer is simple. Would 
you have three of the same picture next to each other if you wanted to create 
a flip book? My guess is no because, in a flip book, you want to create 
animation and animation only comes from changes that will represent 
movement. There are times when you will want to have an identical scene 
and that is okay, just try not to put them together, even if it is because you 
want to lengthen the scene time. There is a Scene Time setting. Please use it.



Now, edit scene three to be different from scene one as well as scene two. 
When this is done, use the single arrows to browse through all the scenes, 
ensuring no two attributes are the same. After that is complete, it is time to 
save the sequence. To do this, click the “arrow going into the folder” icon in 
the Create Sequence window. Name your sequence and click “Save” after 
making sure the Add to Cue and Add to Buttons boxes are unchecked. 

Congratulations!!! You have just made your first sequence in FreeStyler!!! To 
run your new sequence, simply click on the double arrows underneath the 
two single ones. You are now ready to move on to the next chapter, and 
already understand the basis of DMX programming. Of course, there is more 
out there, but it all comes down to the scenes, sequences and cues, which will 
be coming up later.

Feel free to mess around with the program, but be a little careful. I have 
changed a setting a few times without knowing it and spent hours trying to 
find it because I wanted to see what went wrong. I will be telling you all 
about these in chapter 4 or 5. If you do get stuck, you can always reset the 
fixture and start from ground zero. As long as your fixtures are using the 
same address after resetting them, your saved sequences will not be harmed. 

If you think this is fun, wait until the next chapter. I will guarantee you will 
be addicted to this program after seeing the next chapter, but now, it is time 
for the Chapter Quiz......Good Luck......



Chapter 2 Quiz

1. A scene/step is just like a __________ in a motion picture.
2. Two or more scenes are considered a __________.
3. In order to add a scene, you click on the _______ button in the Create 

Sequence window
4. To move from scene to scene, you click on the _______ arrows (answer 

is not left or right)
5. To run the sequence, you click on the _________ arrows.
6. Tell what scene you are in: “Step 3/6”
7. Tell the amount of scenes in this sequence:  “Step 5/7”
8. The minimum amount of scenes per sequence is ________
9. There are two scene variables that can be used to dictate the 

speed/action of a scene. Those two variables (in the gray box) are called 
__________ and __________ time.

10. Are you ready to see your sequence ideas come to life on the screen 
without having any fixtures? (y/n) _________________!!!



Chapter Quiz 2 Answers

1. frame/snapshot
2. sequence
3. “plus”
4. single
5. double
6. Scene 3
7. 7 scenes
8. one scene
9. Fade and Scene
10. I hope you said yes.

You have come a long way so far. If you were to hook up your fixtures right 
now, provided you have an interface and know how to correctly address the 
fixtures, you could see your sequences some to life right now. For those of 
you who do not have fixtures, want to work with your dream fixtures, or 
simply are lazy like me, then read the next chapter....

Chapter 3: From Mind to Screen

In the mean time, get comfortable making sequences and save them. This will 
save you time in the next chapter.

Have fun until we meet again, and thank you for reading my guide.....

rlelek



Chapter 3
Ideas: From Mind To Screen

You may be wondering about something right now. You might be 
thinking how on earth you know where to set your Pan/Tilt for your fixtures 
to have them go where you want them to. Well guess what, there is no other 
way than to drag your fixtures out, hook them to your truss, connect them all, 
and then program as if you were at an event. Doesn't that suck? It sure is a 
good thing that you do not have to do that with software controllers. You 
would have to setup with your lighting hardware and that can be a pain at 
times, depending on exactly how many fixtures you have, not to mention the 
space it will take up. With software, your “setup” will only take up the space 
of your screen and allow you to setup your fixtures with your fingertips. You 
may think I am crazy, but I most certainly am not. I have, in fact discovered 
one of the best kept secrets about DMX software. That secret is called a 
“visualizer”. It isn't so much knowing about it that is the secret, but instead, it 
is knowing HOW to use it. This chapter will cover using the visualizer as 
well as DMX patching. Let's get started......

For visualizing, I do not use the included visualizer. Instead, I “patch” 
the DMX output signal from FreeStyler into Martin's LightJockey. Because 
DMX programming is of the same base and transmits a universal signal, you 
can send almost any signal from one controller to another. You can even 
patch your old hardware programs into FreeStyler as long as you have the 
correct interface, one with a “DMX-In” input. 

If you do not have Light Jockey right now, you may get it for free. All 
you have to do is follow this link to download it, or you can download it from 
freestylerguide.com

ftp://ftp.martin.com/Controller/Lightjockey/LJ_2_7_5_Large.zip

If you like the LightJockey program, you may purchase the interface for 



around $1000-1200. I highly doubt you will want to do this, and this may be 
why you are seeking to learn how to use FreeStyler because the program 
itself is free, and the many compatible interfaces are really inexpensive. 
LightJockey is a powerful program and I suggest you learn how to use it, just 
in case you were to ever come across it. This is why I want to use its 
visualizer and it will also get you comfortable with “patching” signals.

Anyway, once LightJockey is installed, we must go through addressing 
our fixtures once more. This time, you will have to make certain the fixtures 
you use in FreeStyler have the same address that they have in LightJockey. If 
you do not, you will encounter many problems while programming and will 
probably not see the virtual fixtures do what you “tell” them.

To address the fixtures correctly in both programs, please follow the 
instructions below.

● Open Martin's LightJockey and ensure the visualizer is able to launch. 
To do this, select “OffLine-Visualizer>Launch.” Please keep both of 
these windows open for this chapter.

● Open FreeStyler. When it is open, go to “Setup>Add/Remove Fixtures” 
and write down the addresses for each of the fixtures.

● Once you have all of the fixture's addresses written down, switch to LJ 
and open “Setup>Fixture Configuration.” Find the fixtures and add 
them just as you did when we setup FreeStyler. Now we must address 
them. This is the MOST CRUCIAL part. You must assign the same 
address to the fixtures in LJ to the same ones in FreeStyler. If you do 
not, you will not see your sequences correctly visualized and then this 
whole operation will be pointless. 

● To assign the fixture's DMX addresses in LJ, highlight the fixture's 
name in the left window, and type in its corresponding starting address 
into the left window under “DMX Address.” The ending address will be 
filled in automatically. BE CAREFUL! Sometimes LJ has more 
channels per fixture than FreeStyler does. This can cause conflicts. Be 



sure there aren't any fixture sharing an address by looking at the 
window on the left.

● After you have addressed all of your fixtures in LJ, click on the “Save” 
button. When prompted to “Clear data for new fixtures?”, select “Yes.” 
Make sure all of the boxes are checked in the following pop-up window 
and select “OK.” Now, Click the “Close” button on the Fixture 
Configuration window.

● You will now be asked where to place the fixtures. This does not matter 
very much as you will be doing most of your programming through 
FreeStyler. However, feel free to place them where you like by either 
dragging the name of the fixture onto LJ desktop or by clicking “Auto 
Place All.” If you clicked on “Auto Place All,” you will be asked if you 
would like to “place all fixtures on this tab?” Select “Yes.”

● You will now be prompted if you would like to “Auto Arrange.” I 
recommend doing this as it allows for a clean setup on your desktop, 
but beware that this will override your previous placements of your 
fixtures. You may choose to organize by either fixture number or fixture 
type. Just choose the one that works for you. You can always move the 
fixtures around by right-clicking on the desktop and selecting one of the 
options under the “Icons” menu.

● Once that is all done, it is time to apply the “Global Patch.” This will 
allow other signals (such as FreeStyler's) to be fed into LJ and then be 
viewed through LJ's visualizer. First, open “Setup>Global Patch.” then, 
in the pop-up window, select “Options>Patch DMX to Link>Patch to 
Link 1.” When this is complete, select “Apply Patch” and exit the 
window, applying changes (Yes) if you are prompted to.

● That pretty much does it for the LJ program itself. Now, let's move on 
to its visualizer. If you haven't already, launch the visualizer by 
selecting “Off-Line Visualizer>Launch” from LJ's menu bar.

*Note: You can change the Offline-Visualizer's settings, such as 



launching upon LJ's startup, by using the                                         
“Offline- Visualizer>Preferences” menu.

● You are now greeted by a black room frame. Think of it as a canvas in 
which you are to paint your ideas and thoughts. There are virtually 
infinite possibilities with this program. You may be wondering where 
your fixtures are. They haven't arrived yet. They are still in LJ and you 
must ask them to come into the O/V by clicking “Control>Read Fixture 
List.” There they are, already addressed and ready for programming, 
but first, let's get comfortable moving around your virtual venue...

● All of the view controls have a green tint to them and are grouped 
together by default. Among them are:

Zoom Zoom in or out
Camera Move to/from This is similar to Zoom
Camera Inspect Physically moves the camera around
Camera Move Moves the camera 

horizontally/vertically
Camera Swivel Swivels the camera. It is similar to 

how your head moves
Camera Undo Undo Camera Change
Camera Redo Redo Camera Change
Full View Shows the whole room
Select Camera Changes Cameras.

*I doubt you'll use this command.

Take some time to familiarize yourself with these commands now.

● Aside from the 3D view you are currently in, there are a few 2D views 
that will help you mount your fixtures correctly. I recommend using all 
of them before beginning to program because a different position will 
change your programs. These controls are underneath the camera 
controls and need little explanation. The only thing you need to know is 



that there are two different perspectives of a view, for example, one 
person will look to the North, and another will look to the South at the 
same object. It is difficult to explain. You will have to see for yourself.

● To move your fixtures around the room, simply hold down “Alt” and 
click and drag the fixture to its new location. If, for any reason, you 
move the camera instead of the fixture, Click the camera Undo button 
and then click the yellow diagonal arrow in the toolbar. When the arrow 
is selected, it ensures the cammera settings are not being used.

● When you move your fixtures around the room, you cannot adjust the 
rotation of it, only the location. If you ever need to rotate your fixtures, 
such as taking a moving head from the ceiling and placing it on the 
floor, you must adjust the rotation in the “Properties” menu. To access 
this menu, right click anywhere on the screen and select “Properties.” 
You can also access this menu by pressing “Alt+Enter.”

* Please note: when the properties menu is open, you are only changing 
the properties of the RED fixture. Red is the primary fixture, Yellow is 
the secondary, and Gray is showing the fixture is unselected. These 
colors reflect LJ's desktop, showing you which ones you are 
programming. To see this, go to the LJ desktop and select two fixtures 
of your choice. They are now highlighted in the O/V with the Bright 
Red color of the desktop icon corresponding to the Red fixture and the 
Dark Red desktop icon corresponding to the Yellow fixture.

● Once you have your “Virtual Venue” setup the way you like, you should 
save it. Selesct “File>Save As” in the O/V, name it and you can always 
open it in the future.

● That is pretty much the whole Visualizer tutorial. In order to have 
FreeStyler work with the O/V, you must not only have the global patch 
configured, but must also tell it to output its signal so that LJ can 
receive it. To do this open “Setup>FreeStyler Setup.” Then, select 
“Preferences>Misc.” in the setup window. Make sure the box saying 
“Send DMX data to Martin LightJockey” is checked. Click “Save.”



*Note: you may have to do this everytime you start FreeStyler.

● Alright, you are ready to go. If you have any problems, reset the Global 
patch by selecting “Setup>Global Patch” in LJ and then selecting 
“Options> Clear All Patch Information.” To add the patch back in, 
select “Options>Patch DMX In to Link>Patch to Link 1” in the Global 
patch menu.

Thanks for reading and I apologize for the wait. If you have any 
questions, comments, or difficulties, you can contact me in the 
following manners:

Email:  freestylerguide@emailaccount.com

AIM:    FreeStylerDMX

Also, please don't forget to visit my new site. It is....

www.freestylerguide.com

Soon, everything will be consolidated and thrown on the site.

rlelek

*Chapter 4 will consist of advanced programming.

*Chapter 5 will consist of other odds and ends to this program.

mailto:freestylerguide@emailaccount.com
http://www.freestylerguide.com/


Chapter 4
Diving Deeper

I would like to start out congratulating you for making it this far. Often, 
I found myself pulling away from some books after the first few chapters. 
However, I hope I have been able to keep your interest by making DMX as 
fun as possible. If so, please tell me! I'd love to hear your success stories, or 
even about your new job promotion, if you are in need of someone to tell. 
Back to the chapter. You have all waited long enough, so I shall digress no 
longer. 

By now, you programmed basic scenes, and are (hopefully) familiar with the 
DMX terminology I have included in a previous chapter. If not, it's time for a 
review. Go ahead, skim through the chapters and jog your memory. It has 
been a while.

Alright, let's fire up FreeStyler....

● When you arrive at your lighting desktop, please open 2-SCX500's.
● Select both fixtures, one red, one blue, and then click the “show all 

panels” button.
● When all attribute windows are open, click on the trusty old “sequence” 

button. It is time to make two sequences. 
● The sequence choices are up to you, but I would recommend 2 

sequences, with 2 steps each for this tutorial. 
● When finished, save them by clicking the folder with the arrow picture 

going into it. Save them to the default location.
● When you have your sequences ready, it is time to click on a new 

button! Click the button to the right of the “sequence” button. 
● A massive window will open. You are free to remove any other 

windows so long as you saved your two (or more) sequences!
● Go ahead and click “Insert Seq.” over to the right. This is how we will 

bring in sequences you created, at least for now. 
● Drag and drop your sequences to a slot you find fit, they are all the 

same, it's just more of how you like to organize them. 



● I am placing my two sequences in slots (1) and (2). When the sequences 
are inserted, you can move the window you used to open them, or just 
close it all together. 

● Alright! See that little button with a number on it to the left of your 
sequence's names? Go ahead and click on that. It runs your sequence!
Isn't that neat? Yea, it's all well and good, but it only runs it one time 
through.

● What if you want it to repeat the sequence's steps until you select a new 
one? Why, click the little green “refresh” arrows to the right of your 
“sequence slot” (the whole row belonging to settings of your sequence). 
Now, your sequence will run over and over, until you command it to 
either stop or change sequences. 

***FreeStyler CRASHED here for me. Be warned of this. The sound 
activating feature leaves much to be desired as well. Just be aware, this 
is a program, and, like everything else, programs ARE NOT perfect.

I had everything set up for this tutorial, and I can now not finish today. 
Everything was lost when FreeStyler crashed. 
This is a PERFECT example of why to save OFTEN
Do not think it won't happen to you... it will. 

No More Watermarks!
On this guide because people informed me how truly distracting it was.   :D

STOP


